3.4. Docken von Dialogen

3.4.1. Andockleiste

Ein Dock mit hervorgehobenen Andockleisten.

Ab Gimp Version 2.0 gibt es für Sie eine höhere Flexibilität um Dialoge und Fenster anzuordnen. Anstatt jeden Dialog in seinem eigenen Fenster anzuzeigen, wie es in älteren Gimp Versionen der Fall war, können Sie nun Dialoge gruppieren. Dafür stellt ihnen Gimp Containerfenster – sog. Docks – zur Verfügung, die alle Dialoge aufbewahren. Eine Ausnahme gibt es jedoch: Docks können keine Bildfenster, den Einstellungsdialog oder den Dialog zum Erstellen eines neuen Bildes aufbewahren. Diese verbleiben in ihren seperaten Fenstern.

Jedes Dock hat zwei Andockleisten, die jeweils hervorgehoben sein sollten. Die Hervorhebung der Leisten ist jedoch Abhängig von Thema(Theme); so das diese Leisten grau, blau oder eine andere Farbe haben können. Das GTK Standardthema zeigt blaue Leisten.

3.4.2. Sensibler Bereich (Dockgriffe)

Ein Dialog im Dock mit hervorgehobenen sensiblen Bereich zum greifen eines Dialogs aus dem Dock.

Jeder dockbarer Dialog hat seinen eigenen sensiblen Bereich zum ergreifen des Dialogs aus dem Dock. Sie werden beim überfahren des Bereiches merken, dass ihr Mauscursor sich zu einer Hand verändert. Wenn Sie nun mit der Hand auf diesen Bereich mit der linken Maustaste klicken, diese gedrückt halten, den Dialog auf eine Andockleiste eines anderen Docks schieben, können Sie den Dialog von einen in das andere Dock verschieben.

Sie können mehr als einen Dialog auf eine Andockleiste schieben. Bei mehreren Dialogen in einem Dock, können Sie diese per Karteireiter auswählen die im oberen Bereich des Docks angezeigt werden.

3.4.3. Bildliste

Ein Dock mit hervorgehobenen Bildmenü.

Manche Docks haben im oberen Bereich eine Bildliste. Darüber ist es möglich auf die derzeit im Gimp geöffneten Bilder zu zugreifen. Ist die Auto Schaltfläche gedrückt wird Gimp automatisch das aktuelle Bild an dem Sie zur Zeit arbeiten, in der Liste auswählen.

Standardmäßig zeigt das "Ebenen, Kanäle und Pfad" Dock als einziges diese Bildliste. Sie können diese Liste manuell zeigen oder verschwinden lassen, indem Sie das Kontrollkästchen Show Image menu im Reitermenü des Docks aktivieren. Nachfolgend mehr Informationen dazu.

3.4.4. Reitermenü

Ein Dialog im Dock mit hervorgehobener Schaltfläche zum Aufruf des Reitermenüs.

In jedem Dialog ist es möglich, Dockspezifische Funktionen aus einem Reitermenü auszuwählen. Die Funktionalität die im Reitermenü eines Docks zur Auswahl erscheint ist von Dock zu Dock unterschiedlich. Funktionen zum erstellen von neuen Dialogen, schließen oder lösen von Dialogen sind jedoch bei jedem Dock gleich.

Das Reitermenü des Ebenendialogs.

Das Reitermenü gibt ihnen Zugriff zu folgenden Funktionen:

Kontextmenü

Der erste Eintrag des Reitermenüs enthält immer Dialogspezifische Funktionen. Dieses Menü ist ebenfalls über ein rechten Mausklick[2] auf einen Eintrag im Dialogfenster aufrufbar.

Reiter hinzufügen

Dieser Menüeintrag splittet sich in ein Untermenü auf, mit dem Sie die Auswahl aus allen dockbaren Dialogen haben und einen zum Dock hinzufügen können.

Reiter schließen

Mit diesem Menüeintrag können Sie den Dialog schließen. Wenn Sie den letzten Dialog in einem Dock schließen, wird das Dock ebenfalls geschlossen.

Reiter lösen

Dieser Eintrag lößt den Dialog aus dem Dock, und erstellt ein neues Dock inklusive dem Dialog. Sie erziehlen den gleichen Effekt, wenn Sie den Dialog aus dem Dock ziehen und irgendwo auf dem Desktop "fallen" lassen.

Vorschaugröße

Die Vorschaugröße im Untermenü des Reitermenüs.

Die meisten dockbaren Dialoge haben einen Vorschaugröße Eintrag im Reitermenü. Dieser Eintrag öffnet ein Untermenü mit einer Liste von Größen für Miniaturbilder im Dialog. Beispielsweise regelt die Vorschaugröße im Pinseldialog die Größe der angezeigten Pinsel. Voreingestellt ist Medium als Vorschaugröße.

Reiterstil

Reiterstil des Untermenüs im Reitermenü.

Dieser Eintrag ist nur bei mehreren Dialogen in einem Dock verfügbar. Es öffnet ein Untermenü mit der Möglichkeit das Aussehen der Reiter zu beeinflussen. Es gibt fünf Möglichkeiten:

Symbol

Dialogspezifische Icons werden im Reitermenü angezeigt.

Aktueller Status

Dieser Menüeintrag ist nur bei Dialogen verfügbar, die eine Auswahl, z.B. bei Pinseln, Mustern oder Farbverlauf, darstellen. Es zeigt das aktuell ausgewählte Objekt, wie z.B. den Pinsel, das Muster oder den Farbverlauf.

Text

Bei Auswahl zeigen die Reiter im Dock den Namen des Dialoges.

Symbol und Text

Dieser Menüeintrag zeigt die Reiter als Icon in Verbindung mit den Namen der Dialoge an.

Status und Text

Dieser Menüeintrag das aktuell ausgewählte Objekt im Dialog in Verbindung mit dem Namen des Dialoges an.

Als Liste anzeigen; Als Raster anzeigen

Dieser Menüeintrag ist nur bei Dialogen verfügbar, die eine Auswahl, z.B. bei Pinseln, Mustern oder Farbverlauf, darstellen. Sie können die Anordnung der Miniaturbilder beeinflussen indem Sie die Einträge im Dialog entweder als Liste oder übersichtlicher, als Raster anzeigen lassen.

Bildliste anzeigen

Ist das Kontrollkästchen aktiviert, wird im oberen Bereich des Docks ein Menü angezeigt, welches die aktuell geöffneten Bilder beinhaltet. Es ist nicht für Dialoge verfügbar, die sich unter dem Werkzeugfenster befinden.

Automatisch dem aktiven Bild folgen

Sobald die Bildliste angezeigt wird und das Kontrollkästchen aktiviert ist, wird das Bild an dem Sie arbeiten in der Bildliste selektiert.

3.4.5. Reiter entfernen

Ein Dialog im Dock mit hervorgehobenen "Schließen" Schaltfläche.

Um ein Dialog aus dem Dock zu entfernen, klicken Sie einfach die "Schließen" Schaltfläche, welche im anliegenden Schnapschuß hervorgehoben ist.

3.4.6. Dialoge hinzufügen

Die meisten dockbaren Dialoge können über das Dialogmenü im Werkzeugfenster erstellt werden: Datei->Dialoge. Zur Bequemlichkeit, is es möglich voreingestellte Dialoge in einem Dock hinzu zu fügen. Über Datei->Dialoge->Neues Dock erstellen aus dem Werkzeugfenster können Sie folgende Docks erstellen:

Ebenen, Kanäle und Pfade

Erstellt ein Dock inklusive:

  • den Kanaldialog,

  • den Ebenendialog,

  • den Pfaddialog,

  • und den Rückgängig Dialog.

Pinsel, Muster und Farbverläufe

Erstellt ein Dock inklusive:

  • den Pinseldialog,

  • den Musterdialog,

  • den Farbverlaufsdialog,

  • den Farbpalettendialog,

  • und die Schriftartenauswahl.

Verschiedenes

Erstellt ein Dock inklusive:

  • den Ablagendialog,

  • den Bilderdialog,

  • den Dokumentenindex,

  • und den Vorlagendialog.

[Tipp] Tipp

Eine große Auswahl bedeutet nicht gleichfalls, daß jede Auswahl gut ist. Nachfolgend zwei Tips auf denen man achten sollte:

  1. Docken Sie die Werkzeugeinstellungen unter dem Werkzeugfenster um zu jeder Zeit Zugriff darauf zu haben.

  2. Lassen Sie den Ebenendialog jederzeit in einem seperaten Dock geöffnet. Ebenfalls empfehlen wir, die Bildliste angezeigt zu lassen.



[2] Apple Macintosh Benutzer benutzen die linke Maustaste + Strg.