3.4. Dialogs and Docking

Docking Bars

A dock, with docking bars highlighted

In Gimp 2.0 and 2.2, you have a lot of flexibility about the arrangement of dialog windows on your screen. Instead of placing each dialog in its own window, you can group them together using docks. A "dock" is a container window that can hold a collection of persistent dialogs, such as the Tool Options dialog, Brushes dialog, Palette dialog, etc. Docks cannot, however, hold image windows: each image always has its own separate window. They also can't hold non-persistent dialogs, such as the Preferences dialog or the New Image dialog.

Each dock has a set of docking bars, as highlighted in the adjoining figure. These are thin gray bars, very unobtrusive and easy not to notice: most people don't realize that they exist until they are specifically pointed out.

Docking Drag Handles

A dialog in a dock, with the drag handle area highlighted

Each dockable dialog has a drag handle area, as highlighted in the figure on the right. You can recognize this by the fact that the cursor changes to a hand shape when the pointer is over the drag handle area. To dock a dialog, you simply click on its drag handle area, and drag it onto one of the docking bars in a dock.

You can drag more than one dialog onto the same docking bar. If you do, they will turn into tabs, represented by iconic symbols at the top. Clicking on the tab handle will bring a tab to the front, so that you can interact with it.

Image Menu

A dock with an Image Menu highlighted

Some docks contain an Image Menu: a menu listing all of the images open in GIMP, and displaying the name of the image whose information is shown in the dock. You can use the Image Menu to select a different image. If the Auto button is depressed, then the menu always shows the name of GIMP's currently active image, that is, the image you are currently working on.

By default, a "Layers, Channels, and Paths" dock shows an Image Menu at the top, and other types of docks do not. You can always add or remove an Image Menu, however, using the "Show Image Menu" toggle in the Tab menu, as described below. (Exception: you cannot add an Image Menu to the dock that contains the Toolbox.)

Tab Menu

A dialog in a dock, with the Tab menu button highlighted

In each dialog, you can access a special menu of tab-related operations by pressing the Tab Menu button, as highlighted in the figure on the right. Exactly which commands are shown in the menu varies a bit from dialog to dialog, but they always include operations for creating new tabs, or closing or detaching tabs.

Tab menu from the Layers dialog

A Tab menu gives you acces to the following commands:

Context Menu

At the top of each Tab menu is an entry that opens into the dialog's context menu, which contains operations specific to that particular type of dialog. For example, the context menu for the Patterns dialog contains a set of operations for manipulating patterns.

Add Tab

This entry opens into a submenu allowing you to add a large variety of dockable dialogs as new tabs.

Close Tab

This entry closes the dialog. Closing the last dialog in a dock causes the dock itself to close. Choosing this menu entry has the same effect as pressing the "Close Tab" button.

Detach Tab

This entry detaches the dialog from the dock, creating a new dock with the detached dialog as its only member. It has the same effect as dragging the tab out of the dock and releasing it at a random location.

Preview Size

Preview Size submenu of a Tab menu

Many, but not all, dialogs have Tab menus containing a Preview Size option, which opens into a submenu giving a list of sizes for the items in the dialog. For example, the Brushes dialog shows pictures of all available brushes: the Preview Size determines how large the pictures are. The default is Medium.

Tab Style

Tab Style submenu of a Tab menu

This entry is available when multiple dialogs are in the same dock: it opens into a submenu allowing you to choose how the tabs at the top will appear. There are five choices, not all of which will be available for all types of dialogs:

Icon

This choice gives you an icon representing the dialog type.

Current Status

This choice is only available for dialogs that allow you to select something, such as a brush, a pattern, a gradient, etc. It gives you a tab showing a representation of the item currently selected.

Text

This choice gives you a tab showing the dialog type in text.

Icon and Text

This choice gives you wider tabs, containing both an icon and the type of dialog in text.

Status and Text

This choice, where available, shows the item currently selected, as well as the type of dialog.

View as List; View as Grid

These entries are shown in dialogs that allow you to select an item from a set: brushes, patterns, fonts, etc. You can choose whether to view the items as a vertical list, with the name of each beside it, or as a grid, with representations of the items but no names. Each has its advantages: viewing as a list gives you more information, but viewing as a grid allows you to see many more possibilities at once. The default for this varies across dialogs: for brushes and patterns, the default is a grid; for most other things, the default is a list.

Show Image Menu

This is a toggle. If it is checked, then an Image Menu is shown at the top of the dock. It is not available for dialogs docked below the Toolbox.

Auto Follow Active Image

This is a toggle, and it is meaningless unless an Image Menu is being shown. It causes the Image Menu, and hence the contents of the dialog if they are image-related, to change to follow whatever image you are working on at the moment.

Removing Tabs

A dialog in a dock, with the "Close Tab" button highlighted

Le bouton de fermeture d'un onglet

If you want to remove a dialog from a dock, there are two ways you can do it. First, if you click on the drag handle area and drag the dialog away, releasing it someplace other than a docking bar, it will form a new dock in its own right. Second, clicking on the "Close Tab" button (highlighted in the figure to the right) will close the frontmost dialog.

Creating Dialogs

Most dockable dialogs can be created in more than one way, but all of them can be created using the File->Dialogs menu from the Main Toolbox, or by using the Add command in the Tab menu from any dialog. As a convenience, there are also three pre-built docks you can create using the File->Dialogs->Create New Dock menu path from the Main Toolbox:

Layers, Channels and Paths

This gives you a dock containing:

  • The Channels dialog

  • The Layers dialog

  • The Paths dialog

  • The Undo dialog

Brushes, Patterns and Gradients

This gives you a dock containing:

  • The Brushes dialog

  • The Patterns dialog

  • The Gradients dialog

  • The Palettes dialog

  • The Fonts dialog

Misc. Stuff

This gives you a dock containing:

  • The Buffers dialog

  • The Images dialog

  • The Document History dialog

  • The Image Templates dialog

[Tip] Tip

Just because you have a lot of flexibility does not mean that all choices are equally good. There are at least two things we recommend:

  1. Keep the Tool Options dialog docked directly beneath the Main Toolbox at all times.

  2. Keep the Layers dialog around at all times, in a separate dock from the Main Toolbox, with an Image Menu above it. (Use "Show Image Menu" in the dialog Tab menu to display the Image menu if you have somehow lost it.)