2.2. Rectangle Selection Tool

Rectangle Select icon in the Toolbox

The Rectangle Selection tool is designed to select rectangular regions of an image: it is the most basic of the selection tools, but very commonly used. For information on selections and how they are used in GIMP see Selections; for information on features common to all selection tools see Selection Tools.

This tool is also used for rendering a rectangle on an image. To render a filled rectangle, create a rectangular selection, and then fill it using the Bucket Fill tool. To create a rectangular outline, the simplest and most flexible approach is to create a rectangular selection and then stroke it.

If you want to round the edges of a rectangular selection, the easiest method is to shrink it with Select->Shrink from the image menu, and then grow it with Select->Grow, using the same radius both times.

How to Activate

The Rectangle Selection Tool can be activated from an image menu as Tools->Selection Tools->Rect Select; from the Toolbox by clicking on the tool icon ; or from the keyboard using the shortcut r.

Key modifiers

[Note] Note

See Selection Tools for help with modifier keys that affect all these tools in the same way. Only effects that are specific to the Rectangle Select tool are explained here.

  • Ctrl: Pressing the Ctrl key after starting your selection, and holding it down until you are finished, causes your starting point to be used as the center of the selected rectangle, instead of a corner. Note that if you press the Ctrl key before starting to make the selection, the resulting selection will be subtracted from the existing selection.

  • Shift: Pressing the Shift key after starting your selection, and holding it down until you are finished, constrains the selection to be square. Note that if you press the Shift key before starting to make the selection, the resulting selection will be added to the existing selection.

  • Ctrl-Shift: Pressing both keys combines the two effects, giving you a square selection centered on your starting point.

Tool Options

Tool Options for the Rectangle Select tool

[Note] Note

See Selection Tools for help with options that are common to all these tools. Only options that are specific to the Rectangle Select tool are explained here.

Antialiasing

This option performs no function for this tool and is present to unify the user interface between the various selection types.

Auto Shrink Selection

The Auto Shrink Selection checkbox will make your next selection automatically shrink to the nearest rectangular shape available on the image layer. The algorithm for finding the best rectangle to shrink to is "intelligent", which in this case means that it sometimes does surprisingly sophisticated things, and sometimes does surprisingly strange things. In any case, if the region that you want to select has a solid-colored surround, auto-shrinking will always pick it out correctly. Note that the resulting selection does not need to have the same shape as the one you sweep out.

If Sample Merged is also enabled, then Auto Shrink will use the pixel information from the visible display of the image, rather than just from the active layer. For further information regarding Sample Merge, see the glossary entry Sample Merge.

Size Constraints

Size Constraint Option Menu for the Rectangle Select tool

This menu allows you the option of constraining the shape of the rectangle in three different ways.

  • Free Select.  This option places no constraint on the rectangle.

  • Fixed Size.  This will allow you to manually specify a size for the selection using the Width, Height, and Unit controls.

  • Fixed Aspect Ratio.  This option allows you to resize the selection while keeping the aspect ratio fixed according to the two numbers entered in the Width and Height controls.