2. File

Contents of the File menu

2.1. New

The New Image dialog

The dialog allows you to create a new image window and to set its specifications. You may have more than one image on your screen.

The Dialog for creating a new image can be called in the following ways, from the toolbox and image-menu: File->New.

You can also open the Dialog by using a keyboard shortcut: Ctrl+N

Basic Options

Template

Template menu (default)

Instead of filling in all the numbers by hand, you can choose the dimensions of the image from a menu of templates, representing shapes that are more or less commonly useful. If there is an image shape that you use often, and it does not appear in the list, you can create a new template using the Templates dialog.

Image Size

Here you set the width and height of the new image. The default units are pixels, but you can switch to some other unit if you prefer, using the adjoining menu. If you do, note that the resulting pixel size will be determined by the X and Y resolution (which you can change in the Advanced Options), and by the setting of "Dot for Dot", which you can change in the View menu.

[Note] Note

Please keep in mind, that every Pixel of an image is stored in the memory. If you're creating large files with a high density of pixels, Gimp will need some time for every function you're applying to the image.

Portrait/Landscape buttons

These buttons toggle between Portrait and Landscape mode. Concretely, their effect is to exchange the values for Width and Height. If the X and Y resolutions are different (in Advanced Options), then these values are exchanged also.

Advanced Options

New Image dialog (Advanced Options)

These are options that will mainly be of interest to more advanced users. (Gimp 2.0 does not distinguish between Basic and Advanced Options; all of the options are visible at the same level.)

X and Y resolution

These values come into play mainly in relation to printing: they do not affect the size of the image in pixels, but they determine its size on paper when printed. They can also affect the way the image is displayed on the monitor: if "Dot for Dot" is switched off in the View menu, then at 100$ zoom, Gimp attempts to display the image on the monitor at the correct physical size, as calculated from the pixel dimensions and the resolution. The display may not be accurate, however, unless the monitor has been calibrated. This can be done either when Gimp is installed, or from the Display tab of the Preferences dialog.

Colorspace

Colorspace menu

You can create the new image as either an RGB image or a grayscale image. You cannot create an indexed image directly in this way, but of course nothing prevents you from converting the image to indexed mode after it has been created.

Fill

Fill menu

You have four choices for the solid color that will fill the new image's background layer:

  • The Foreground color as shown in the Main Toolbox.

  • The Background color as shown in the Main Toolbox.

  • White

  • Transparent. If this option is chosen, then the Background layer in the new image will be created with an alpha channel; otherwise not.

Comment

You can write a descriptive comment here. The text will be attached to the image as a "parasite", and will be saved along with the image by some file formats (but not all of them).