2. Quoi de neuf dans Gimp?

Gimp 1.0 a évolué progressivement vers la version stable 1.2 largement répandue. Trois ans plus tard, l'équipe de développement a estimé que Gimp était à nouveau proche de la stabilité et présentait suffisamment de changements pour justifier une nouvelle version stable 2.0. Voyons quels sont ces améliorations.

2.1. Quoi de neuf dans Gimp 2.0?

Tout d'abord quelques chiffres: la base de code Gimp contient à peu près 230.000 lignes de code C, et la plupart de ces lignes ont été réécrites depuis la version 1.2. Néanmoins, l'utilisateur de Gimp 1.2 ne sera pas désorienté. Les développeurs ont beaucoup nettoyé le code, investissement qui, s'il n'est pas immédiatement visible pour l'utilisateur, facilite la maintenance et rendra les additions futures moins pénibles.

Outils de base

Les outils de base de Gimp 2 ne sont pas très différents de ceux de ceux de gimp 1. L'outil «Sélection de régions par couleur» se trouve maintenant dans la Boîte à outils, mais il existait déjà dans le menu Sélection. L'outil Transformation a été scindé en plusieurs outils spécialisés: Rotation, Changer d'échelle, Cisaillement et Perspective

L'interface utilisateur des outils a aussi changé significativement. La fenêtre "Options des outils" reste maintenant constamment ouverte même si on change d'outil et elle peut être attachée en permanence sous la Boîte à outils.

Options des outils

Les «Options des outils» ont plusieurs possibilités nouvelles:

Tous les outils de sélection ont maintenant trois boutons pour changer de mode: Remplacer, Ajouter, Soustraire et Intersection ce qui est plus pratique que le jeu de touches complexe antérieur.

Avec les outils de transformation, les boutons permettent de choisir sur quel objet, calque, sélection ou chemin, portera la transformation.

Les outils de dessin ont maintenant leurs propres paramètres de brosse, de dégradé et de motif. L'utilisation la roue de la souris sur l'aperçu de brosse y fait défiler l'ensemble des brosses.

Interface utilisateur

Gimp2 utilise maintenant l'ensemble de librairies GTK2+. L'une des caractéristiques les plus intéressantes est la possibilité d'avoir plusieurs dialogues réunis au sein d'onglets dans une même fenêtre. On peut avoir des boîtes de dialogue fixes sur l'écran. Les boîtes de dialogue offrent un petit menu de personnalisation qui vous donne plus de flexibilité dans l'organisation de votre espace de travail

La fenêtre d'image offre de nouvelles fontionnalités. Elles ne sont pas activée par défaut mais peuvent l'être dans le menu «Préférences/Interface/Fenêtres d'images». Par exemple «Afficher le contour de la brosse» vous permet ce voir le contour de la brosse quand vous utilisez un outil de dessin. Dans la sous-section «Apparence» vous pouvez décider si une barre de menu est présente ou non en haut de la fenêtre d'image. Vous pouvez choisir de travailler en mode plein-écran. Les options de visibilité sont également disponibles par un clic droit sur l'image faisant apparaître un menu local avec l'entrée «Affichage». On peut aussi accéder à ce menu en cliquant sur le petit bouton marqué d'un triangle en haut à gauche de la fenêtre d'image. Les options choisies dans Préférences sont des options utilisées par défaut pour toutes les images. Les mêmes options fixées à partir du menu local ne sont valables que pour l'image actuelle. (La touche F11 permet de basculer le mode plein-écran)

Les accélérateurs clavier de Gimp 2 facilitent l'accès aux menus. Par exemple, si la barre de menus est présente, tapez Alt-F-N pour créer une nouvelle image. Sans barre de menus, tapez Shift-F10 pour ouvrir le menu local qui reproduit les entrées de la barre de menus, et utilisez les touches fléchées ou F puis N pour créer la nouvelle image. Les accélérateurs clavier sont différents des raccourcis clavier: les accélérateurs permettent de naviguer dans les menus tandis que les raccourcis permettent d'accéder directement à une fonction. Par exemple, le raccourci Ctrl-N est la façon la plus rapide de créer une nouvelle image.

Pour faciliter l'accès à vos commandes les plus utilisées, Gimp a fourni depuis longtemps la possibilité de créer vos propres raccourcis clavier: quand un item de menu est sélectionné, il suffisait de taper les touches voulues pour le raccouci pour qu'il soit créé. Cette possibilité existe toujours mais a été désactivée par défaut dans Gimp 2 afin d'éviter les conflits accidentels avec les raccourcis existants.

Gimp possède ses propres combinaisons de touches pour les entrées de ses menus. Si vous voulez remplacer ces combinaisons par celle de Photoshop, renommez le «menurc» de votre répertoire utilisateur en «oldmenurc» et renommez «ps-menurc» en «menurc».

Gérer les Onglets et les fenêtres attachables

Gimp 2 introduit un système de dialogues en onglets vous permettant de regrouper plusieurs dialogues dans une même fenêtre. Presque toutes les boîtes de dialogue peuvent être glissées-déposées dans une autre fenêtre de dialogue et y apparaître sous forme d'onglet.

En outre, en bas de chaque boîte de dialogue se trouve une barre d'attachement des dialogues où vous pouvez déposer les dialogues attachables sous le groupe d'onglets du haut.

Rédaction de scripts

«Python-fu» est maintenant l'interface d'écriture extene standard de Gimp. Cel signifie que vous pouvez utiliser des fonctions Gimp en Python ou inversement utiliser Python pour écrire des greffons Gimp. Python est relativement facile à comprendre même par les débutants, surtout si on le compare au langage Sheme, qui rappelle LISP, précédemment utilisé par Gimp 1.

Gimp-Perl n'est plus livré avec la distribution standard de Gimp 2, mais il reste disponible dans un paquetage à part. Gimp-Perl n'est accepté que par les systèmes Unix. Il inclut à la fois un langage d'écriture simple et la possibilité de coder des interfaces plus polies grâce au module perl Gtk2. La manipulation directe des pixels est disponible à travers PDL.

Script-fu, basé sur Scheme, a les mêmes inconvénients qu'avant: peu intuitif, difficile à utiliser et manquant d'un environnement de développement véritable. Il a néanmoins un avantage majeur par rapport à Python-fu: Les scripts Script-fu sont interprétés directement par Gimp sans avoir besoin d'installer un logiciel complémentaire. Python-fu, lui, necessite l'installation d'un paquetage pour le langage Python.

L'Outil Texte

Le grand problème avec l'outil Texte dans Gimp 1 était que le texte ne plus être modifié un fois produit. Dans Gimp 1 il y avait aussi un greffon «Texte dynamique» qui permettait de créer des calques texte spéciaux que vous pouviez conserver pour les modifier, mais il était bogué et affreux à utiliser

L'outil Chemins

Le nouvel outil Chemins a une interface entièrement nouvelle. Les chemins n'ont plus besoin d'être fermés. Un chemin peut être formés de plusieurs composants distincts. Trois modes différents sont possibles: Tracer, Édition, Déplacer.

En mode Tracer, vous pouvez créer un chemin, ajouter des nœuds à un chemin existant et modifier la forme de la courbe en glissant les segments ou en glissant les poignées d'un nœud.

En mode Éditer, vous pouvez ajouter ou supprimer un nœud sur un segment, changer la forme de la courbe ou raccorder deux composants.

En mode Déplacer, vous pouvez déplacer les composants du chemin, ensemble ou séparément.

L'outil chemin comporte deux autres nouveautés. Non seulement Gimp 2 peut importer les images SVG mais il peut aussi garder les chemins SVG intacts comme chemins Gimp. Cela signifie que Gimp peut collaborer avec votre outil de dessin vectoriel favori. L'autre nouveauté qui a amélioré l'outil Chemins est la possibilité de «tracer» automatiquement un chemin avec la brosse de votre choix.

Autres améliorations

Quelques autres améliorations, en bref:

  • Haute qualité de lissage, surtout dans l'outil Texte.

  • On peut changer le décor des icônes et des menus. Vous pouvez créer votre propre lot d'icônes et l'appliquer à la Boîte à outils en utilisant l'option Interface du menu Préférences. Un thème «small» (petit) est inclus dans la distribution standard.

  • Une image peut être enregistrée comme modèle et être utilisée à créer de nouvelles images.

  • Il y a quatre nouveaux modes de fusion des calques qui gisent l'un au dessus de l'autre: Lumière dure, Lumière douce, Extraction de grain, Fusion de grain.

  • S'il y a une sélection active, vous pouvez découper l'image à la taille de cette sélection par l'option Image/Découper.

  • Gimp a maintenant une grille , complémentaire des guides, rendant plus facile le positionnement des objets.

  • Le dialogue des Calques est plus cohérent, en ce qu'il n'y a plus de fonctions cachées, accessibles uniquement par le menu local. Toutes les fonctions concernant les calques sont accessibles par le sous-menu Calque.

  • Les filtres d'affichage couleur sont maintenant disponibles via le menu Affichage/Filtres d'affichage: ils vous permmettent de modifier l'affichage des couleurs sur votre écran, sans modifier l'image elle-même. Cela est utile aux personnes ayant un problème de vision des couleurs.

  • Le dialogue de sélection des couleurs possède un mode CMJN associé à l'onglet représentant une imprimante.

  • Les méta-données EXIF des appareils photo numériques sont maintenant gérées en mode lecture et écriture pour les fichiers JPEG.

  • Les animations MNG sont maintenant gérées. le format MNG peut être considéré comme un PNG animé. Il a tous les avantages du PNG sur le GIF, tels le nombre plus grand de couleurs, 256 niveaux de transparence, et , peut-être plus important, l'absence de problème de licence. C'est un standard Web, et les navigateurs les plus répandus l'acceptent.

  • The GIMP Animation package now does onion-skinning, a bluescreen feature was added as well as audio support.

    Je n'ai pas su traduire. Désolé!

  • Un mixeur de canaux est apparu dans Filtres/Couleurs.