4.3. Calques

Une bonne façon de se représenter une image Gimp est de la voir comme une pile de trasparents: dans la terminologie Gimp, ces transparents s'appellent des calques. Il n'y a pas de limite, autre que celle de la capacité en mémoire du système, au nombre de calques possibles. Il n'est pas rare, pour les utilisateurs avancés, de travailler sur des images contenant des douzaines de calques.

L'organisation des calques d'une image est visualisée dans la fenêtre de Dialogue des Calques, qui est, après la Boîte à outils, la plus importante dans Gimp. L'aspect de cette fenêtre de dialogue et son mode d'utilisation sont décrits dans la section Dialogue des Calques, mais nous en verrons quelques aspects ici, en relation avec les propriétés des calques qu'ils affichent.

Chaque image ouverte à un moment donné ne possède qu'un seul élément peignable (NdT:"drawable" en anglais). Ce peut-être un calque, mais aussi beaucoup d'autres choses, comme un canal, un masque de calque, un masque de sélection. En fait, tout objet pouvant être peint avec un outil de peinture. Si un calque est actif, il est surligné dans le dialogue des calques et son nom est affiché dans l'aire d'état de la fenêtre d'image. Sinon, vous l'activez en cliquant dessus. Si aucun calque n'est surligné, cela signifie que l'élément peignable est autre chose qu'un calque.

Dans la barre de menu en haut de la fenêtre d'image, vous trouverez le menu Calque, contenant plusieurs commandes agissant sur le calque actif de l'image. On accède au même menu par un clic droit dans le Dialogue des Calques.

Chaque calque d'une image possède plusieurs attributs importants:

Nom

Chaque calque a un nom. Il lui est affecté automatiquement lors de sa création, mais vous pouvez en changer en double- cliquant dessus dans le Dialogue des Calques, ou par un clic droit dans ce dialogue pour faire apparaître le menu local où vous trouverez la commande Éditer les attributs du calque.

Présence ou absence d'un canal alpha

Comme expliqué précédemment, un canal alpha encode l'information sur le degré de transparence de chaque pixel du calque. Il est visible dans le Dialogue des Canaux. Le blanc représente une opacité complète, le noir une transparence complète et les tons de gris les tranparences partielles. Mais tous les calques n'ont pas besoin d'avoir un canal alpha. Souvent, le calque du bas dans une image (appelé «Arrière-plan») n'en a pas: ce qui signifie qu'il est totalement opaque en tous ses points. Les calques sans canal alpha sont créés quand vous ouvrez une image dans un format qui n'accepte pas la transparence, ou quand vous créez une nouvelle image en utilisant Fichier->Nouveau avec un Type de remplissage transparent, ou quand vous aplatissez une image en un seul calque.

Tout calque autre que celui du bas doit avoir un canal alpha. Pour le calque du bas, il est optionnel. Beaucoup d'opérations ne peuvent pas être réalisées sur des calques sans canal alpha. Par exemple, déplacer un calque dans la pile des calques, mais aussi toute opération portant sur la transparence. Vous pouvez ajouter un canal alpha à un calque qui en manque en utilisant la commande Calque->Transparence->Ajouter un canal Alpha, ou par un clic droit sur le Dialogue des calques pour ouvrir le menu local et choisir Ajouter un canal Alpha. Pour supprimer un canal Alpha, activez le calque du bas en cliquant dessus dans le Dialogue des Calques et choisissez Calque->Transparence->Aplatir à moitié.

Type de calque

Le type de calque est déterminé par le type d'image (voir la section précédente) et la présence ou l'absence d'un canal Alpha. Voici les types de calques possibles:

  • RVB

  • RVBA

  • Nuances de gris

  • Nuances de gris A

  • Indexé

  • Indexé A

La raison en est que la plupart des filtres (dans le menu Filtres) n'acceptent qu'un sous-ensemble de types de calques, et apparaissent en grisé si le calque actif n'a pas le type voulu. Le plus souvent vous pouvez rectifier cela en changeant le mode d'image ou en ajoutant ou supprimant un canal Alpha.

Visibilité

Il est possible d'enlever temporairement le calque d'une image sans le détruire, en cliquant sur le symbole «œil ouvert» dans le Dialogue des Calques. On dit qu'on rend le calque visible ou invisible. Quand vous travaillez sur des images comportant plusieurs calques avec des opacités variables, vous aurez une meilleure vision d'un calque particulier en rendant les autres invisibles.

[Note] Note

Si vous Shift-cliquez sur le symbole œil d'un calque, cela rendra tous les autres calques invisibles.

Lier plusieurs calques

Si vous cliquez entre l'œil et la vignette du calque, vous faites apparaître une icône en forme de chaîne qui permet de grouper des calques pour effectuer une opération simultanément sur plusieurs calques (par exemple avec l'outil Déplacer).

Taille

Dans Gimp, les dimensions d'un calque ne correspondent pas forcément aux dimensions de l'image qui le contient. C'est particulièrement vrai pour les calques de texte qui ne contiennent que le texte et rien d'autre. De même, quand vous créez un nouveau calque par copier-coller, les dimensions de ce nouveau calque sont adaptées à son contenu. Dans la fenêtre d'image, les limites du calque actif sont indiquées par un pointillé jaune et noir.

Vous ne pouvez bien sûr pas dessiner en dehors des limites du calque actif. Si cela vous gène, vous pouvez modifier les dimensions du calque à l'aide d'une des commandes que vous trouverez dans le menu Calque.

[Note] Note

La quantité de mémoire utilisée par un calque dépend de ses dimensions et non de son contenu. Si donc vous travaillez sur de grandes images ou des images avec un grand nombre de calques, il peut valoir le coup de réduire les calques à leur taille minimum.

Opacité

L'opacité d'un calque détermine le degré avec lequel il laisse voir les couleurs des calques sous-jacents. Elle varie de 0 à 100, 0 étant la transparence complète et 100 l'opacité complète.

Mode

Le Mode d'un calque détermine la façon dont les couleurs du calque sont combinées aux couleurs des calques sous-jacents pour produire la couleur visible sur l'image. Voir le glossaire à la rubrique Modes des calques

Masque de calque

En plus du canal Alpha, il existe une autre manière de contrôler la transparence d'un calque: c'est de lui ajouter un Masque de calque qui est un élément peignable en nuances de gris associé au calque. Un calque n'a pas de masque de calque par défaut: il doit être ajouté spécifiquement. Les Masques de calque et la façon de travailler avec eux, sont décrits dans une section suivante.

"Garder la transparence

Dans le coin en haut à droite du Dialogue des calques est une case à cocher «Garder la transparence». Si elle est cochée, le canal Alpha du calque actif est bloqué. Rien de ce que vous ferez sur une partie transparente du calque ne sera pris en compte.

Créer de nouveaux calques

Il y a plusieurs façons de créer un nouveau calque dans une image. Voici les plus importantes:

  • En choisissant Calque->Nouveau calque dans le menu image. Voir Le dialogue Nouveau Calque

  • En choisissant Calque->Dupliquer le calque dans le menu image. Cela crée un nouveau calque au sommet de la pile des calques, copie parfaite du calque courant actif.

  • Quand vous coupez quelque chose et que vous le collez en utilisant Ctrl-V ou Éditer->Coller, le résulat est une «sélection flottante» qui est une sorte de calque temporaire. Avant de faire quoi que ce soit, vous devez ancrer la sélection flottante à un calque existant, ou la convertir en calque normal. Dans ce dernier cas, la taille du nouveau calque sera ajustée à celle du matériel collé.