3.4. 对话框和停靠栏

停靠条

一个停靠栏,其停靠条高亮

在 GIMP 2.0 和 2.2 中,在对话框在屏幕的布局上您有很大的灵活性。您能用停靠栏将对话框组合在一起,而不用每个对话框放置在其单独的窗口中。一个“停靠栏”是一个容器窗口,它能容纳一组连续对话框,如工具选项对话框,画笔对话框和图案对话框等。不过停靠栏不能容纳图像窗口:每个图像都有自己单独的窗口,它们也不能装非连续的对话框,如首选项对话框或新图像对话框。

每个停靠栏有一系列停靠条。在毗邻的图形中高亮。它们是些窄的灰色常条,非常不显眼而不容易注意:大多数人没有意识到它们的存在,直到它们被特别地指出。

停靠拖动臂点

一个停靠栏中的对话框,其拖动臂点区域高亮

每个可停靠对话框都有一个拖动臂点区域,在右边的图形中高亮。当您把鼠标指针放在拖动臂点区域时,其光标就变成一个手的形状。您可以通过简单点击拖动臂点区域并拖动它到停靠栏的一个停靠条上来停靠对话框。

您能拖动不止一个对话框到同一个对话条上。当您这样做时,它们将变成页签,并在顶端表现为图标页志。点击页签臂点将使一个标签呈现在面前,这时您可以与它交互。

图像菜单

一个图像菜单高亮的停靠栏

有一些停靠栏包含一个图像菜单:该菜单中列出 GIMP 中打开的所有图像并显示将在停靠栏中列出信息的图像的名字。您可以用图像菜单来选取不同的图像。如果按下“自动”按钮,该菜单就会显示 GIMP 当前活动图像的名字,即您当前正在操作的图像。

“图层,通道和路径”停靠栏默认是在顶部显示图像菜单,而其它类型停靠栏则不同。不过您可以使用页签菜单中的“显示图像菜单”添加或移除图像菜单,下面将有详细介绍。(例外:您不能在包含工具箱的停靠栏上添加图像菜单。)

页签操作

一个停靠栏中的一个对话框,其页签菜单按钮高亮

在每个对话框中,您能通过按下页签菜单按钮来取得一些特殊的页签相关操作的菜单,正如右边图形中高亮的。准确的说,菜单中显示的命令在各个对话框中稍有不同,但是它们都有添加页签,关闭或漂移页签的操作。

图层对话框中的页签菜单

页签菜单中有这些命令:

上下文菜单

每个页签菜单顶部一项是对话框的上下文菜单,它包括针对特殊类型对话框的操作。比如,图案对话框的上下文菜单包括一组处理图案的操作。

添加页签

该项打开一个子菜单,它让您添加多种多样的停靠对话框作为新的页签。

关闭页签

该项关闭对话框,关闭停靠栏的最后一个对话框将关闭该停靠栏。选取该菜单项和按“关闭页签”按钮效果相同。

漂移页签

该项从停靠栏中分离对话框,并新建一个只包含该分离对话框的停靠栏。它和拖动页签到停靠栏外并在随机位置释放效果相同。

预览大小

页签菜单的预览大小子菜单。

有许多但不是全部的对话框其页签菜单包含一个“预览大小”的选项,在其子菜单中列出了对话框中项目的大小。比如,画笔对话框显示所有可用画笔的图片:预览大小就是决定这些图片的大小。默认是“中”。

页签风格

页签菜单的页签风格子菜单

该项在多个对话框在同一停靠栏中时可用:它打开一个子菜单让您选择顶部的页签如何显示。其中有五种选择,但它们并不是所有类型对话框中都可用。

图标

该选择用图标表示对话框类型。

当前状态

该选择对那些可以选取比如画笔,图案,渐变等的对话框可用。它用一个页签显示当前选取的物品。

文字

该选择用一个页签以文字的方式显示对话框类型。

图标和文字

该选择使用一个更宽的包括图标和对话框类型文字的页签。

状态和文字

当该选择可用时,就会显示当前选取的物品和对话框类型文字。

以列表方式查看;以阵列方式查看

这些项在对话框中有可以选择一些东西:画笔,图案和字体等时可用。您可以选择是使这些项目呈垂直列表排列并且名字显示在旁边,还是阵列排列并且没有名字。它们各有各的优点:以列表方式查看显示更多信息,而以阵列方式查看让您能同时看到更多可选项。其默认值随对话框不同而不同:对画笔和图案默认是阵列;而对大多数其它的,其默认是列表。

显示图像菜单

这是一个开关。勾选它时,会在停靠栏顶部显示图像菜单,但对停靠在工具箱下面的对话框无效。

自动跟随活动图像

这是一个开关,当没有显示图像菜单时它是没有意义的。它使图像菜单和对话框内容(如果是与图像相关的)自动变为您当前正在操作的图像。

删除页签

一个停靠栏中的对话框,其“关闭页签”按钮高亮。

假如您想从一个对话栏中删除一个对话框,这有两种能实现的方法。首先,如果您在点击拖动臂点区域并将对话框拖走,在没有停靠条的地方释放鼠标键,它将自习形成一个新的停靠栏。第二,点击“关闭页签”按钮(在右边的图形中高亮)将关闭最前端的对话框。

创建对话框

大部分可停靠的对话框都能有不只一种方式来创建,不过它们都能通过下列步骤来创建,在主工具箱中: 文件->对话框 菜单,或在任何对话框的页签菜单中使用添加命令。为方便起见,三个内建的停靠栏可以通过如下方式创建,在主工具箱中: 文件->对话框->创建新停靠栏 菜单。

图层,通道和路径

这个停靠栏包括:

  • 通道对话框

  • 图层对话框

  • 路径对话框

  • 撤消对话框

画笔,图案和渐变

这个停靠栏包括:

  • 画笔对话框

  • 图案对话框

  • 渐变对话框

  • 色板对话框

  • 字体对话框

杂项

这个停靠栏包括:

  • 缓冲区对话框

  • 图像对话框

  • 文档历史对话框

  • 图像模板对话框

[提示] 提示

只是您有很大灵活度并不意味着所有选择都是一样好。这里至少有两件事是我们推荐的:

  1. 一直保持工具选项对话框直接停靠在主工具箱下面。

  2. 一直保持图层对话框在单独一个独立与主工具箱的停靠栏上,上部放置图像菜单。(如果由于某种原因丢掉了,使用对话框页签菜单中的“显示图像菜单”来显示图像菜单。)