2.2. 矩形选择工具

工具箱中的矩形选择图标

矩形选择区域工具被用作在图像或图层上选取矩形区域:它是最基本的选择工具,但使用很频繁。关于选区的更多信息以及如何使用请看选区;关于所有选择工具共同的特性请看选择工具

该工具也用作在图像上绘制矩形。要绘制一个填充了的矩形,先创建一个矩形选区,然后用油漆桶填充工具对其填充。而创建一个矩形框的最简单灵活的方法就是先创建一个矩形选区,然后勾画它。

要使矩形选区的四边变弯曲,最简单是方法就是先用图像菜单的 选择->收缩 ,然后用 选择->增长。这两步中都使用相同的半径。

启动工具

按如下步骤启动矩形选择工具,在图像菜单中:工具/选择工具/矩形选择

也可以点工具图标:

r 键将转到矩形选择。

相关按键(默认值)

[注意] 注意

关于控制键用相同方式影响这些工具的帮助请看选择工具,下面只解释对矩形选择工具特有的影响。

  • Ctrl: 按住Ctrl同时创建一个矩形选区会同时做两件事。第一,创建的选区将以您选取的起点作为中心,而如果不按Ctrl, 会以您选取的起点作为一角。第二,Ctrl会使选取呈减去模式。如果只想完成其中一个动作,可以在松开左键前松开Ctrl键,这样选取只变为减去模式,而不会以选取的起点作为中心。

  • Shift: 按住Shift同时创建一个选区将做两件不同的事。第一,它保持选区的长宽相同。第二,该组合键使选取呈合并模式。如果只想完成其中一个动作,可以在松开左键前松开Shift键,这样选取只变为合并模式,而不会约束其长宽相同。

  • 使用 Ctrl-Shift 可以干一系列事。每个键单独使用都可以干两件事。首先,选择模式将变为相交。其次,选区将以其起始点作为中心(上面讨论过)且长宽相同(上面也讨论过)。读者可以在使用矩形选择同时按住 Ctrl-Shift 时尝试在放开左键前松开一个键或全部键。

选项

矩形选择工具的工具选项

[注意] 注意

这些工具共用的选项请看选择工具。下面只解释矩形选择工具所特有的选项。

边缘平滑

该选项对这个工具没有用,只是为了统一不同选择工具的用户界面而放在这里。

自动收缩选区

自动收缩选区勾选框将使下次选取自动收缩到图像图层上最近的可用矩形上。

如果位样合并也被勾选,那么自动收缩将使用图像所有图层上的像素信息。要得到关于位样合并更多的信息请看位样合并

大小限制

矩形选择工具的大小限制菜单

该菜单中有限制矩形形状的三种方式。

  • 自由选择.  该选项对矩形没有限制。

  • 固定大小.  该选项让您手工输入选区的宽度高度单位

  • 固定宽高比.  该选项让您改变选区大小并和输入的宽度和高度值保持一定的比例。