3.8. 克隆工具

工具栏中的克隆工具图标

克隆工具用当前画笔从图像或图案中拷贝。它有许多用处:其中最重要的就是修复数码照片中有问题的区域,即用其它区域的像素“涂掉”它们。该技术需要一定时间学习,不过一旦掌握您就会发现它非常强大。另一个重要用处就是勾画图案线或曲线:请看图案

如果要对图像而不是图案进行克隆,您需要告诉 GIMP 源图像--按下 Ctrl 键并点击所有使用的源图像。要用克隆工具进行涂画就必须这样做:否则工具光标会显示“禁止”标志。

从图案中克隆使,图案是平铺的;也就是说当拷贝的点在图案边界外时,它会掉转到相反边界并继续,仿佛图案是一个接着一个,不断重复的。而从图像中克隆时就不会那样:当越过源边界时,克隆工具就停止不再进行任何改变。

您可以从任何可画(即任何图层,图层蒙板和通道)克隆到任何其它可画中。甚至可以切换到快速蒙板模式中在选区模板间进行克隆。如果目标不支持拷贝的颜色(例如从 RGB 图层中克隆到索引图层或图层蒙板),这些颜色就会被转变为尽可能接近近似颜色。

启动工具

克隆工具在图像菜单的: 工具->涂画工具->克隆;也可以双击该工具图标: ;或使用快捷键 c

相关按键

请看笔刷工具简介中在所有笔刷工具中效果相同的控制键。

Ctrl

Ctrl:如果从图像中克隆,Ctrl 键用作选取源:从图案中克隆时它没有作用。在图像显示中点击的同时按下 Ctrl 键,并使所要处理的图层成为活动图层(在图层对话框中高亮),这样就能从任何图像的任何图层中克隆。当工具选项的对齐为“不对齐”或“对齐”时,您所点击的点就是克隆的原点:开始用克隆工具涂画后,就会使用该点的图像数据。在源选择模式中,光标就会变为十字标志。

选项

克隆工具的工具选项

[注意] 注意

关于许多或所有笔刷工具共用工具选项的介绍请看笔刷工具简介

图案

选择涂画使用的图案,点击图案图标打开图案选择对话框。该选项只适合从图案源中克隆时。

该选项决定数据是从上面所说的图案中拷贝,还是从打开的图像中。如果选择“图像源”,在用该工具进行涂画前,您就必须告诉 GIMP 作为源的图层,用 Ctrl-点击它实现。

对齐

对齐模式设定源位置和每一笔划间的位移关系。

不对齐

对齐

记录

上面的截图将鼠标光标显示为一个红色矩形,而源点显示为一个黑色十字。

  • 不对齐.  该模式中每个笔划将被分别对待。对每个笔划而言,第一次点击点将被拷贝到源的原点;笔划间没有任何联系。而不对齐模式中,当笔划交叉时常常会产生不协调。

  • 对齐.  该模式中涂画时第一次点击将设定克隆结果和源原点的位移,紧接着的笔划都使用与该位移相同的位移。因此您可用涂画任意多的笔划,它们之间显得协调和平滑。

    如果要改变位移,可以先转为不对齐模式,涂画一笔后,在转回到对齐模式。紧接这的笔划就会使用和第一笔相同的位移。

  • 记录.  该模式从源中拷贝像素到目标中对应位移的像素上。其最大用途就在相同图像中从一个图层克隆到另一个图层。在从图案中克隆时也比较有用,它能让图案的左右边界在目标图层中准确地放置。

更多信息

透明部分

克隆工具对透明部分的效果有点复杂。您不能克隆完全透明:对完全透明的源克隆时,目标上没有任何效果。对部分透明的源克隆时,其效果由源的不透明度决定。假设克隆工具使用 100% 不透明度和一个硬质画笔:

  • 从半透明黑色克隆到白色上产生灰色。

  • 从半透明黑色克隆到黑色上产生黑色。

  • 从半透明白色克隆到白色上产生白色。

  • 从半透明白色克隆到黑色上产生灰色。

克隆不会增加透明性,不过它会降低它,除非图层中“保持透明部分”是勾选的。从不透明区域克隆到半透明区域会产生不透明效果;从半透明区域克隆到另一半透明区域会增加其不透明度。

“滤镜”画笔

有一些用克隆工具得到惊人效果的鲜为人知的方法。其中一个就是创建“滤镜画笔”,即用画笔产生滤镜的效果。要达到此效果,首先复制准备对其进行处理的图层,然后对副本使用滤镜。接着开启克隆工具,在其工具选项中设置“源”为“图像源”而“对齐”为“记录”,Ctrl-点击副本使其为源,并对原始图层进行涂画:这样被滤镜处理过的图像数据就涂画到原始图层中了。

历史画笔

您可以使用与 Photoshop 的“历史画笔”相同的方法来模拟它,它让您用画笔有选择地撤销或重做所进行的操作。要达到此效果首先复制图像;然后在原始图像中用撤销或撤销历史对话框回到图像历史中所要的状态。(这一步必须在原始图像中而不是拷贝中进行,因为复制图像无法复制撤销历史。)现在开启克隆工具,设定“源”为“图像源”而“对齐”为“记录”,Ctrl-点击一个图像的图层,并对另一个图像对应的图层进行涂画。这样就完成了,至于是“撤销画笔”还是“重做画笔”由您如何做来决定。