4.4. 路径菜单

路径对话框菜单

通过在路径对话框的路径项中点击右键,或选取路径对话框页签菜单顶部项(“路径菜单”)将打开路径菜单,其中有影响路径的大部分操作。

路径工具

路径工具是激活路径工具的另一种方式,用作创建和处理路径。它也可以用工具箱或快捷键 B (代表 Bezier)来打开。

编辑路径属性

编辑路径属性唤出一个可以改变路径名字的小的对话框。也可以双击路径对话框列表中路径名字开启它。

新建路径

新建路径创建一个新路径,将其名字添加到路径对话框列表中,并且使该路径成为图像的活动路径。它会唤出一个输入路径名字的对话框。由于新建路径没有锚点,所以在对使用它之前需要用路径工具给它一些。

升高路径

升高路径将路径在路径对话框列表中向上提升一格。由于路径在列表中的顺序没有功能上的差别,因此这里只是让您方便地组织它们。

降低路径

降低路径将路径在路径对话框列表中向下移动一格。由于路径在列表中的顺序没有功能上的差别,因此这里只是让您方便地组织它们。

复制路径

“复制路径”创建一份当前路径的拷贝,赋予它一个唯一的名字,添加到路径对话框列表中,并使它成为图像的当前路径。只有在原路径可见时拷贝才可见。

[注意] 注意

需要注意的是,对可见路径进行拷贝将使该路径从图像显示中“消失”:这是因为路径以 XOR 模式画出的,它有奇怪的特性--对物体画两次将使其“未画”。虽然您看不到路径,但它们仍在那里:移动其中一个,就能看到它们。

删除路径

删除路径将移除当前选中的路径。

合并可见路径

合并可见路径将图像中所有可见路径(即那些在路径对话框中前面有“眼睛”标志的)变成一个单独路径的组成部分。在需要将它们用相同方式进行勾画时比较方便。

路径到选区;添加到选区;从选区中减去;与选区相交

这些命令都是将活动路径转变为一个选区,并和已存在选区用选定方式进行组合。(“路径到选区”将丢弃已存在选区并用产生的新路径代替。)如果有必有,任何没有封闭的路径组件都会以用直线连接起始和结束锚点的方式封闭。这样产生的路径会被选区的“蚂蚁线”紧紧跟随,不过其对应关系有时可能不是十分完美。

选区到路径

有多种方式进行该操作:

  • 在图像菜单栏中, 选择->到路径

  • 路径对话框菜单中, 选区到路径

  • 路径对话框底部的选区到路径按钮。

  • 路径工具的工具选项中“选区到路径”按钮。

选区到路径从图像选区中新建一个路径。这样产生的路径会被选区的“蚂蚁线”紧紧跟随,不过其对应关系有时可能不是十分完美。

将两维的选区蒙板转变为一维的路径要需要使用一些特殊算法:可以用高级选项进行调整,按住 Shift 并点击路径对话框底部的选区到路径按钮将唤出高级选项对话框,其中有 20 个选项和变量,它们都有难懂的名字。高级选项其实只是为开发者提供的,其使用超出了该文档讨论的范围。一般来说,使用选区到路径不用考虑它是如何实现的(除非您想要了解),它会按您的要求进行。

勾画路径

有多种方式进行该操作:

  • 在图像菜单栏中, 编辑->勾画路径

  • 路径对话框菜单中,勾画选区

  • 路径对话框底部勾选路径按钮。

  • 路径工具的工具选项的勾画选区按钮。

“勾画选区”用多种多样的线形和勾画选项在图像活动图层上绘制活动路径。更多信息请看勾画

复制路径

“复制路径”将活动路径拷贝到路径剪切板中,这样就能够将该路径复制到不同图像中。

[提示] 提示

也可以通过在路径对话框中拖动路径图标到目标图像显示中来实现复制和粘贴路径。

粘贴路径

粘贴路径从路径剪切板中新建一个路径,将它添加到路径对话框列表中,并使其成为图像的活动路径。如果以前没有复制路径到剪切板中,该菜单项是不可用的。

导入路径

“导入路径”从 SVG 文件中新建一个路径:它会弹出一个文件选择对话框。有关 SVG 文件和 GIMP 路径的关系请看路径章节。

导出路径

导出路径让您将路径保存到文件中:它会弹出一个用作指定文件名和位置的文件保存对话框。以后就可以用导入路径命令将该路径添加到任何 GIMP 图像中。保存路径的格式是 SVG:这就意味着像 SodipodiInkscape 一样的矢量图形程序也可以导出您保存的路径。有关 SVG 文件和 GIMP 路径的关系的更多信息请看路径章节。