15. 缓冲区对话框

缓冲区对话框

缓冲区是临时存放图像数据的地方,它们在剪切或拷贝可画部分时被创建(图层和图像蒙板等)。当您使用 编辑->拷贝编辑->剪切时,数据就存放在全局缓冲区中。而当使用 编辑->缓冲区->命名复制编辑->缓冲区->命名剪切时,会弹出一个需要您命名保存数据的缓存区的对话框。创建缓冲区的数量没有硬性限制,不过它们都要耗费一定内存。

缓冲区对话框中显示现有所有命名缓冲的内容,并可以用多种方式对它们进行操作。在最上方也显示全局缓冲区的内容,不过它仅仅是个显示而已,您不能对它做任何事。

缓冲区对话框是可停靠对话框;更多信息请看对话框和停靠栏。有多种方式开启该对话框:

[小心] 小心

命名缓冲区只在该进程中存在,保存其内存的唯一方式就是把它们粘贴在图像中。

阵列/列表模式

缓冲区对话框(阵列模式)

在缓冲区对话框的页签菜单中可以选择以阵列方式查看以列表方式查看。阵列模式中,缓冲区按矩形阵列排列,列表模式中,它们竖直排列,缓冲区内容预览,名字和它的像素尺寸对应地排成一行。

使用缓冲区对话框

缓冲区菜单

通过点击显示区域的一个缓冲区,使其成为活动缓冲区,它会被缓冲区菜单或对话框底部按钮的粘贴命令所使用。双击一个缓冲区则使其内容粘贴到活动图像中;这是运行“粘贴缓冲区”命令的快捷方式。

对话框底部有四个按钮。它们所做的操作也可以通过缓冲区菜单和图像菜单中的 编辑->缓冲区子菜单完成。

  • 粘贴缓冲区.  该命令将选中的缓冲区的内容以浮动选区的形式粘贴到活动图像中。它与普通粘贴命令间的唯一区别就是,它使用选中的缓冲区而不是全局剪贴板缓冲区。

  • 粘贴缓冲区进入.  该命令将选中的缓冲区的内容以浮动选区的形式粘贴到活动图像的选区中。它与普通粘贴入命令间的唯一区别就是,它使用选中的缓冲区而不是全局剪贴板缓冲区。

  • 粘贴缓冲区为新图像.  该命令用选中的缓冲区的内容新建一个单个图层的图像。它和普通粘贴为新图像命令的唯一区别就是,它使用选中的缓冲区而不是全局剪贴板缓冲区。

  • 删除缓冲区.  该命令删除选中的命名缓冲区,它不会询问。您不能删除全局缓冲区。

[注意] 注意

您可以使用在对话框页签菜单的“预览大小”子菜单改变对话框中缓冲区预览的大小。