Chapter 5. Working With Menus

Customizing Your Menus

You can modify the contents of the following menus:

  • Applications menu

  • Desktop Preferences menu

You use the following GNOME Desktop components to customize menus:

  • Menus on panels

  • Nautilus file manager

When you use panels to customize your menus, you use the menu item popup menu. For more information, see the section called “Menu Item Popup Menu”.

When you use the file manager to customize your menus, you must access the Applications menu or the Desktop Preferences menu from within the file manager. To access the Applications menu or the Desktop Preferences menu, open a file manager window.

To access menus in the file manager, access one of the following URIs in the file manager:

Menu

Enter this URI

Applications menu

applications:///

Desktop Preferences menu

preferences:///

For more information on the file manager, see Nautilus File Manager.

To Add a Menu

To add a menu, perform the following steps:

  1. In a file manager window, access the location where you want to add the menu. For example, if you want to add a menu to the Applications menu, enter applications:/// URI.

  2. Choose File->Create Folder. An untitled folder is added to the menu. The name of the folder is selected.

  3. Type a name for the folder, then press Return.

The next time that you log out then log in again, the menu is in the assigned location.

To Add a Launcher to a Menu

To add a launcher to a menu, perform the following steps:

  1. Right-click on any item in the menu to which you want to add the launcher.

  2. Choose Entire menu->Add new item to this menu. A Create Launcher dialog is displayed.

  3. Enter the properties of the launcher in the Create Launcher dialog. For more information on the elements in the Create Launcher dialog, see Working With Panels.

  4. Click OK.

To Add a Launcher to an Empty Menu

To add a launcher to an empty menu, perform the following steps:

  1. In a file manager window, access the menu where you want to add the launcher.

  2. Choose File->Create Launcher. A Create Launcher dialog is displayed.

  3. Enter the properties of the launcher in the Create Launcher dialog. For more information on the elements in the Create Launcher dialog, see Working With Panels.

  4. Click OK.

To Copy a Launcher to a Menu

To copy an existing launcher to a menu, perform the following steps:

  1. In a file manager window, access the location from which you want to copy the launcher. For example, if you want to copy a launcher from the Applications menu, enter applications:/// URI.

  2. Select the launcher that you want to copy, then choose Edit->Copy File.

  3. In a file manager window, access the location to which you want to copy the launcher.

  4. Choose Edit->Paste Files. The launcher is added to the new location.

Alternatively, you can drag the launcher from one location to another.

The next time that you log out then log in again, the launcher is in the new menu location.

To Edit the Properties of a Menu

To edit the properties of a menu, perform the following steps:

  1. Right-click on any item in the menu that you want to edit.

  2. Choose Entire menu->Properties. A Launcher Properties dialog is displayed.

  3. Modify the properties of the menu in the Launcher Properties dialog. For more information on the elements in the Launcher Properties dialog, see Working With Panels.

  4. Click OK.

To Edit a Menu Item

To edit a menu item, perform the following steps:

  1. Right-click on the item that you want to edit.

  2. Choose Properties. A Launcher Properties dialog is displayed.

  3. Modify the properties of the launcher in the Launcher Properties dialog. For more information on the elements in the Launcher Properties dialog, see Working With Panels.

  4. Click OK.

To Delete an Item from a Menu

To delete an item from a menu, use the menu item popup menu. To delete an item from a menu, perform the following steps:

  1. Right-click on the item that you want to delete.

  2. Choose Remove this item.