Chapter 7. Nautilus File Manager

Browsing Your Files

You can use file browser windows to browse your file system.

File Browser Windows

You can access file browser windows in the following ways:

  • Click on the the file browser window launcher on the top edge panel.

  • Choose Applications->Browse Filesystem.

  • Select a folder from a file object window, then choose File->Browse Folder. A file browser window displays the contents of your folder in the view pane.

Figure 7.1, “Contents of a Folder in a File Browser Window” shows a sample file browser window that displays the contents of the Home folder.

Figure 7.1. Contents of a Folder in a File Browser Window

 A folder in a file browser window.

Note

In other distributions of the GNOME Desktop, the Home toolbar button might have another designation, for example, Documents.

File Browser Window Components

Table 7.1, “File Browser Window Components” describes the components of file browser windows.

Table 7.1. File Browser Window Components

Component

Description

Menubar

Contains menus that you use to perform tasks in the file manager.

Toolbar

Contains buttons that you use to perform tasks in the file manager.

Location bar

Contains the following elements:

  • Location field: Enables you to specify a file, folder, or URI that you want to view.

  • Zoom buttons: Enable you to change the size of items in the view pane.

  • View as drop-down list: Enables you to choose how to show items in your view pane.

Side pane

Performs the following functions:

  • Shows information about the current file or folder.

  • Enables you to navigate through your files.

The side pane contains a drop-down list that enables you to choose what to show in the side pane. You can choose from the following options:

  • Information

  • Emblems

  • History

  • Notes

  • Tree

To display the side pane, choose View->Side Pane.

View pane

Shows the contents of the following:

  • Particular types of files

  • Folders

  • FTP sites

  • Locations that correspond to special URIs

Statusbar

Displays status information.

You can access files and folders from a file browser window in the following ways:

  • Enter a path to the file or folder in the Location field.

  • Click on an item in the tree view.

  • Double-click on a folder or a file in the view pane.

You can also open a popup menu from file manager windows. To open this popup menu right-click in a file manager window. The items in this menu depend on where you right-click. For example, when you right-click on a file or folder, you can choose items related to the file or folder. When you right-click on the background of a view pane, you can choose items related to the display of items in the view pane.

View Pane

The view pane can display the contents of the following:

  • Particular types of files

  • Folders

  • FTP sites

  • Locations that correspond to special URIs

File browser windows contain viewer components that enable you to display particular types of file in the view pane. For example, you can use a text viewer to display text files in the view pane.

Displaying a file in the view pane provides the following benefits:

  • Uses less system resources than when you launch an application.

  • Takes less time than when you launch an application.

However, you cannot edit a file in the view pane.

File browser windows also include views that enable you to display the contents of your folders in different ways. For example, you can display the contents of a folder in the following types of view:

  • Icon view: Shows the items in the folder as icons.

  • List view: Shows the items in the folder as a list.

  • Audio view: Shows only the audio items in the folder.

Use the View menu to choose how to display a folder. For more information on views, see the section called “Using Views to Display Your Files and Folders”.

Side Pane

To display the side pane, choose View->Side Pane. You can choose what information you want to view in the side pane. You can choose to display one of the following:

  • Information

    Displays an icon that represents the current file or current folder. Also displays information about the current file or current folder. If a file is displayed in the view pane, buttons appear in the side pane. The buttons enable you to perform actions on a file, other than the default action.

  • Emblems

    Contains emblems that you can add to a file or folder. For more information on emblems, see the next section.

  • History

    Contains a history list of files, folders, FTP sites, and URIs that you have recently visited.

  • Notes

    Enables you to add notes to your files and folders.

  • Tree

    Displays a hierarchical representation of your file system. You can use the Tree to navigate through your files.

To close the side pane, click on the X button at the top right of the side pane.

To Show and Hide File Browser Window Components

You can show and hide file browser window components as follows:

  • To hide the side pane, choose View->Side Pane. To display the side pane again, choose View->Side Pane again.

  • To hide the toolbar, choose View->Toolbar. To display the toolbar again, choose View->Toolbar again.

  • To hide the location bar, choose View->Location Bar. To display the location bar again, choose View->Location Bar again.

  • To hide the statusbar, choose View->Statusbar. To display the statusbar again, choose View->Statusbar again.

To Display Your Home Folder

To display your home location, perform one of the following actions from file browser windows:

  • Enter the home path in the Location field.

  • Choose Go->Home.

  • Click on the Home toolbar button.

The file browser window displays the contents of your home location. To reload the display, click on the Reload button.

To Display a Folder

You can display the contents of a folder in any of the following ways:

  • Double-click on the folder in the view pane.

  • In the Location field, type the path of the folder that you want to display, then press Return. The Location field includes an autocomplete feature. As you type a path, the file manager reads your file system. When you type enough characters to uniquely identify a directory, the file manager completes the name of the directory in the Location field.

  • Use the Tree in the side pane. For more information, see the section called “Using the Tree From the Side Pane”.

  • Use the Back toolbar button and the Forward toolbar button to browse through your navigation history.

To change to the folder that is one level above the current folder, choose Go->Up. Alternatively, click on the Up toolbar button.

To reload the display, click on the Reload button.

If you cannot find the folder that you want to display, you can use Search Tool. To start Search Tool, choose Actions->Search for Files.

Using the Tree From the Side Pane

The Tree displays a hierarchical representation of your file system. The Tree provides a convenient way to browse and to navigate your file system. To display the Tree in the side pane, choose Tree from the drop-down list at the top of the side pane.

In the Tree, folders are represented as follows:

Folder State

Graphic Representation

Closed folder

Right arrow

Open folder

Down arrow

Table 7.2, “Tree Tasks” describes the tasks that you can perform with the Tree, and how to perform the tasks.

Table 7.2. Tree Tasks

Task

Action

Open the Tree.

Choose Tree from the drop-down list at the top of the side pane.

Close the Tree.

Choose another item from the drop-down list at the top of the side pane.

Open a folder in the Tree.

Click on the arrow next to the folder in the Tree.

Close a folder in the Tree.

Click on the arrow next to the folder in the Tree.

Display the contents of a folder in the view pane.

Select the folder in the Tree.

Display the contents of a file in the view pane.

Select the file in the Tree.

You can set your preferences so that the Tree does not display files. For more information, see the section called “To Set Views Preferences”.

Using Your Navigation History

The file browser window maintains a history list of files, folders, FTP sites, and URI locations. You can use the history list to navigate to files, folders, FTP sites, and URI locations that you have recently visited. Your history list contains the last ten items that you viewed. The following sections describe how to navigate your history list.

To clear your history list choose Go->Clear History.

To Navigate Your History List Using the Go Menu

To display a list of previously-viewed items, choose the Go menu. Your history list is displayed in the lower part of the Go menu. To open an item in your history list, choose the item from the Go menu.

To Navigate Your History List Using the Toolbar

To use the toolbar to navigate your history list, perform one of the following actions:

  • To open the previous file, folder, or URI in your history list, click on the Back toolbar button.

  • To open the next file, folder, or URI in your history list, click on the Forward toolbar button.

  • To display a list of previously-viewed items, click on the down arrow to the right of the Back toolbar button. To open an item from this list, click on the item.

  • To display a list of items that you viewed after you viewed the current item, click on the down arrow to the right of the Forward toolbar button. To open an item from this list, click on the item.

To Navigate Your History List Using History in the Side Pane

To display the History list in the side pane, choose History from the drop-down list at the top of the side pane. The History list in the side pane displays a list of your previously-viewed items.

To display an item from your history list in the view pane, click on the item in the History list.

Viewing Files in a File Browser Window

The file manager contains viewer components that enable you to display particular types of file in a file browser window. For example, you can display the following types of files in a file browser window:

  • Plain text files

  • PNG files

  • Joint Photographic Experts Group (JPEG) files

To reload the contents of a file browser window, choose View->Reload. To stop loading an item, choose View->Stop.

When you display a file in a file browser window, the viewer component might add menu items to the file manager menus. The menu items relate to the file type that is displayed. For example, when you display a PNG file, the Edit menu contains flip and rotate menu items.

Also, when you display some types of file in a file browser window, you can use the file manager zoom buttons to change the size of the item.

To Bookmark Your Favorite Locations

To access an item in your bookmarks, choose the item from the Bookmarks menu. You can add your favorite locations to your Bookmarks menu. You can add bookmarks to files and folders in your file system, to FTP sites, or to URI locations.

To Add a Bookmark

To add a bookmark, display the item that you want to bookmark in the view pane. Choose Bookmarks->Add Bookmark.

To Edit a Bookmark

To edit your bookmarks perform the following steps:

  1. Choose Bookmarks->Edit Bookmarks. An Edit Bookmarks dialog is displayed.

  2. To edit a bookmark, select the bookmark on the left side of the Edit Bookmarks dialog. Edit the details for the bookmark on the right side of the Edit Bookmarks dialog, as follows:

    Dialog Element

    Description

    Name

    Use this text box to specify the name that identifies the bookmark in the Bookmarks menu.

    Location

    Use this field to specify the location of the bookmark.

  3. To delete a bookmark, select the bookmark on the left side of the dialog. Click Delete.

Adding Notes to Files and Folders

You can add notes to files or folders. You can add notes to files or folders in the following ways:

  • From the properties dialog

  • From Notes in the side pane

To Add a Note Using the Properties Dialog

To add a note to a file or folder, perform the following steps:

  1. Select the file or folder to which you want to add a note.

  2. Choose File->Properties. A properties dialog is displayed.

  3. Click on the Notes tab. In the Notes tabbed section, type the note.

  4. Click Close to close the properties dialog. A note emblem is added to the file or folder.

To delete a note, delete the note text from the Notes tabbed section.

To Add a Note Using Notes in the Side Pane

To add a note to a file or folder, perform the following steps:

  1. Open the file or folder to which you want to add a note in the view pane.

  2. Choose Notes from the drop-down list at the top of the side pane. To display the side pane, choose View->Side Pane.

  3. Type the note in the side pane. A note emblem is added to the file or folder in the view pane, and a note icon is added to the side pane. You can click on this icon to display the note.

To delete a note, delete the note text from Notes in the side pane.