Chapter 7. Nautilus File Manager

Managing Your Files and Folders

This section describes how to work with your files and folders.

Drag-and-Drop in the File Manager

You can use drag-and-drop to perform several tasks in the file manager. When you drag-and-drop, the mouse pointer provides feedback about the task that you perform. Table 7.8, “Drag-and-Drop in the File Manager” describes the tasks that you can perform with drag-and-drop. The table also shows the mouse pointers that appear when you drag-and-drop.

Table 7.8. Drag-and-Drop in the File Manager

Task

Action

Mouse Pointer

Move an item

Drag the item to the new location.

Move pointer.

Copy an item

Grab the item, then press-and-hold Ctrl. Drag the item to the new location.

Copy pointer.

Create a symbolic link to an item

Grab the item, then press-and-hold Ctrl-Shift. Drag the item to the location where you want the symbolic link to reside.

Symbolic link pointer.

Ask what to do with the item you drag

Grab the item, then press-and-hold Alt. Drag the item to the location where you want the item to reside. Release the mouse button. A popup menu appears. Choose one of the following items from the popup menu:

  • Move here

    Moves the item to the location.

  • Copy here

    Copies the item to the location.

  • Link here

    Creates a symbolic link to the item at the location.

  • Set as Background

    If the item is an image, sets the image to be the desktop background. You can use this command to set the desktop background and the view pane background.

  • Cancel

    Cancels the drag-and-drop operation.

Ask pointer.

To Select Files and Folders

You can select files and folders in several ways in the file manager. Table 7.9, “Selecting Items in the File Manager” describes how to select items in file manager windows and on the desktop.

Table 7.9. Selecting Items in the File Manager

Task

Action

Select an item

Click on the item.

Select a group of contiguous items

In icon view, drag around the files that you want to select.

In list view, click on the first item in the group. Press-and-hold Shift, then click on the last item in the group.

Select multiple items

Press-and-hold Ctrl. Click on the items that you want to select.

Alternatively, press-and-hold Ctrl, then drag around the files that you want to select.

Select all items in a folder

Choose Edit->Select All Files.

To perform the default action on an item, double-click on the item. You can set your file manager preferences so that you click once on a file to execute the default action. For more information, see the section called “To Set Behavior Preferences”.

To Move a File or Folder

The following sections describe the ways that you can move a file or folder.

Drag to the New Location

To drag a file or folder to a new location, perform the following steps:

  1. Open two file manager windows.

  2. In one window, select the folder from which you want to move the file or folder. In the other window, select the folder to which you want to move the file or folder.

  3. Drag the file or folder that you want to move to the new location in the other window.

To move the file or folder to a folder that is one level below the current location, do not open a new window. Instead, drag the file or folder to the new location in the same window.

Cut and Paste to the New Location

You can cut a file or folder and paste the file or folder into another folder, as follows:

  1. Select the file or folder that you want to move, then choose Edit->Cut File.

  2. Open the folder to which you want to move the file or folder, then choose Edit->Paste Files.

To Copy a File or Folder

The following sections describe the ways that you can copy a file or folder.

Drag to the New Location

To copy a file or folder, perform the following steps:

  1. Open two file manager windows.

  2. In one window, select the folder from which you want to copy the file or folder. In the other window, select the folder to which you want to copy the file or folder.

  3. Grab the file or folder, then press-and-hold Ctrl. Drag the file or folder to the new location in the other window.

To copy the file or folder to a folder that is one level below the current location, do not open a new window. Instead, grab the file or folder, then press-and-hold Ctrl. Drag the file or folder to the new location in the same window.

Copy and Paste to the New Location

You can copy a file or folder and paste the file or folder into another folder, as follows:

  1. Select the file or folder that you want to copy, then choose Edit->Copy File.

  2. Open the folder to which you want to copy the file or folder, then choose Edit->Paste Files.

To Duplicate a File or Folder

To create a copy of a file or folder in the current folder, perform the following steps:

  1. Select the file or folder that you want to duplicate.

  2. Choose Edit->Duplicate. Alternatively, right-click on the file or folder, then choose Duplicate.

    A copy of the file or folder appears in the current folder.

To Create a Folder

To create a folder, perform the following steps:

  1. Select the folder where you want to create the new folder.

  2. Choose File->Create Folder. Alternatively, right-click on the background of the window, then choose Create Folder.

    An untitled folder is added to the location. The name of the folder is selected.

  3. Type a name for the folder, then press Return.

Templates and Documents

You can create templates from documents that you frequently create. For example, if you often create invoices, you can create an empty invoice document and save the document as invoice.doc in the $HOME/Templates folder.

You can also access the templates folder from a file browser window. Choose Go->Templates.

The template name is displayed as a submenu item in the Create Document menu.

You can also create subfolders in the template folder. Subfolders display as submenus in the menu.

You can also share templates. Create a symbolic link from the template folder to the folder containing the shared templates.

To Create a Document

If you have document templates, you can choose to create a document from one of the installed templates.

To create a document perform the following steps:

  1. Select the folder where you want to create the new document.

  2. Choose File->Create Document. Alternatively, right-click on the background of the view pane, then choose Create Document.

    The names of any available templates are displayed as submenu items from the Create Document menu.

  3. Double-click on the template name for the document that you want to create.

  4. Rename the document before saving to the appropriate folder.

To Rename a File or Folder

To rename a file or folder perform the following steps:

  1. Select the file or folder that you want to rename.

  2. Choose Edit->Rename. Alternatively, right-click on the file or folder, then choose Rename.

    The name of the file or folder is selected.

  3. Type a new name for the file or folder, then press Return.

To Move a File or Folder to Trash

To move a file or folder to Trash perform the following steps:

  1. Select the file or folder that you want to move to Trash.

  2. Choose Edit->Move to Trash. Alternatively, right-click on the file or folder, then choose Move to Trash.

Alternatively, you can drag the file or folder to the Trash object on the desktop.

Note

When you move a file or folder from a removable media to Trash, the file or folder is stored in a Trash location on the removable media. To remove the file or folder permanently from the removable media, you must empty Trash.

To Delete a File or Folder

When you delete a file or folder, the file or folder is not moved to Trash, but is deleted from your file system immediately. The Delete menu item is only available if you select the Include a Delete command that bypasses Trash option in the File Management Preferences dialog.

To delete a file or folder perform the following steps:

  1. Select the file or folder that you want to delete.

  2. Choose Edit->Delete. Alternatively, right-click on the file or folder, then choose Delete.

To Create a Symbolic Link to a File or Folder

A symbolic link is a special type of file that points to another file or folder. When you perform an action on a symbolic link, the action is performed on the file or folder to which the symbolic link points. However, when you delete a symbolic link, you delete the link file, not the file to which the symbolic link points.

To create a symbolic link to a file or folder, select the file or folder to which you want to create a link. Choose Edit->Make Link. A link to the file or folder is added to the current folder.

Alternatively, grab the item to which you want to create a link, then press-and-hold Ctrl-Shift. Drag the item to the location where you want to place the link.

By default, the file manager adds an emblem to symbolic links.

Note

The permissions of a symbolic link are determined by the file or folder to which a symbolic link points.

To View the Properties of a File or Folder

To view the properties of a file or folder, perform the following steps:

  1. Select the file or folder whose properties you want to view.

  2. Choose File->Properties. A properties dialog is displayed.

  3. Use the properties dialog to view the properties of the file or folder.

  4. Click Close to close the properties dialog.

To Change Permissions

Permissions are settings assigned to each file and folder that determine what type of access users can have to the file or folder. The following table lists the permissions that you can set for files and folders, and the effect of the permission on files and folders:

Permission

File

Folder

Read

Permission to read the file.

Permission to list the contents of the folder.

Write

Permission to make changes to the file.

Permission to create and delete files in the folder.

Execute

Permission to run the file as a program. This is only relevant if the file is a program or script.

Permission to access files in the directory.

You can set permissions for different types of user. The following table lists the types of user that you can set for which you can set permissions:

User Category

Description

Owner

The user that created the file or folder.

Group

The group to which the owner belongs.

Others

All other users who are not in the group to which the owner belongs.

To change the permissions on a file or folder perform the following steps:

  1. Select the file or folder that you want to change.

  2. Choose File->Properties. A properties dialog is displayed.

  3. Click on the Permissions tab. In the Permissions tabbed section, use the drop-down lists and check boxes to change the permissions for the file or folder. The following table describes the dialog elements on the Permissions tabbed section:

    Element

    Description

    File owner

    To change the owner of the file or folder, select the owner from the drop-down list.

    File group

    To change the group to which a file or folder belongs, select the group from the drop-down list.

    Owner

    Select the permissions that you want to apply to the owner of the file or folder.

    Group

    Select the permissions that you want to apply to the group to which the owner of the file or folder belongs.

    Others

    Select the permissions that you want to apply to all other users who are not in the group to which the owner belongs.

    Text view

    Displays the permissions that you select from the Read, Write, and Execute options, in text format.

    Number view

    Displays the permissions that you select from the Read, Write, and Execute options, in text format.

    Last changed

    Displays the date and time that the file or folder was last modified.

  4. Click Close to close the properties dialog.

Using Trash

Trash icon, empty.

You can move the following items to Trash:

  • Files

  • Folders

  • Desktop objects

If you need to retrieve a file from Trash, you can display Trash and move the file out of Trash. When you empty Trash, you delete the contents of Trash permanently.

To Display Trash

You can display the contents of Trash in the following ways:

  • From a file browser window

    Choose Go->Trash. The contents of Trash are displayed in the window.

  • From a file object window

    Choose Places->Trash. The contents of Trash are displayed in the window.

  • From the desktop

    Double-click on the Trash object on the desktop.

To Empty Trash

You can empty the contents of Trash in the following ways:

  • From a file browser window

    Choose File->Empty Trash.

  • From the desktop

    Right-click on the Trash object, then choose Empty Trash.